Recently, I experienced I/O issues while trying to scan documents on my Samsung SL-C460W. It has worked flawlessly with Windows 10 before, so seems like something changed in the latest Windows 10 build.

Reinstalling the Samsung scanner driver didn’t help, also scanning by WIA did not work. Communicating with the scanner was no longer possible, while printing works without any issues.

Seems like due to changes in recent Windows 10 builds two file have been removed which are required by the scanner driver to be able to communicate with the device.

Luckily Samsung has provied a fix for that. Officially it’s meant for some other multi-functional device, but it works fine with the C460 series, too.

Find it on the Samsung webpage.



  • About

    Destabilizing cishetero amatonormativity. Providing disruption as a service. Once you know the way, you see it in all things. Unless you puke, faint or die, keep going. Also we never asked for this. I̸͝t̸̑ ̵̽i̷͗s̶͐ ̵͝a̶͒l̷ ͍r̷ ̗͕e̵͑a̶͌d̸̄y̷̚ ̶̀ ͓͑t̷̚ô̶o̸ ̥ ̶́ ̡l̷͝a̶̽t̵͒ė̶.̸ ̋͑

  • Got something interesting?

    You think you got something which should be on this site? Then contact us. You want something removed from this site, because you think it should not be here? Then go fuck yourself. This is a free website. Free as in freedom. It tolerates every opinion from everyone. However, it does not tolerate things which are illegal according to the Swiss legislation.

  • Disclaimer

    We cannot be held responsible for any kind of direct, indirect or consequential damages caused by the stuff and or opinions we provide here. Use this on your own risk. Don’t blame us if something goes wrong or totally messes up your machine, your life or whatever. If this is unacceptable for you then go away and never come back again. Thank you!